Bílý vrch
icon TrekBuddy
www.trekbuddy.net
Outdoor companion.
  • internal / bluetooth / simulator GPS
  • offline raster maps
  • smart GPX / raw NMEA logs
  • waypoints and simple navigation
  • custom views
  • MIDP and Symbian phones
  • Blackberry
  • Android
Visit wiki to see all features, guides and howtos. Project tracker.

Partners:    (Polish/Polski)(Polski) Compass mapy      (Polish/Polski)(Polski) Galileos mapy      (Polish/Polski)(Polski) CartoMedia      (Czech/Èesky)(Èesky) Eaglesoft trasy      (Polish/Polski)(Polski) ExpressMap     

 FAQFAQ   SearchSearch   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
1.2.0
Goto page Previous  1, 2, 3, 4  Next
 
Post new topic   Reply to topic    TrekBuddy Forum Index -> Versions
View previous topic :: View next topic  
Author Message
haddock



Joined: 16 Oct 2007
Posts: 209
Location: AT

PostPosted: Mon Mar 11, 2013 8:17 am    Post subject: Re: HTML-Tags are shown GC LongDesc Reply with quote

Don Atorre wrote:
Before i upgraded to 1.20 i used 1.11, which was superior. But a downgrade back from 1.20 to 1.11 failed because of a cetification error, in german "Zertifikatsfehler".


Use this "new" v. 1.1.1. Kruch signed it with a valid certificate:
http://www.trekbuddy.net/dev/haddock/1.1.1-2013/

_________________
ZTE Axon 7 Mini / Nokia E61 DTBM (Dedicated TrekBuddy Machine)
Back to top
View user's profile Send private message
kruch
Site Admin


Joined: 02 Jul 2006
Posts: 5665

PostPosted: Mon Mar 11, 2013 8:35 am    Post subject: Reply with quote

Is 1.11 superior for other reasons than the html-tags issue? The bug is most probably a side-effect of my optimization effort Sad

Hola @nokianero, I have received multiple reports about camera problems in Android, I'll try to fix it in 1.2.1.
Back to top
View user's profile Send private message
Don Atorre



Joined: 08 Apr 2010
Posts: 15

PostPosted: Mon Mar 11, 2013 11:29 am    Post subject: Reply with quote

@ kruch:
the 1.20 is, as far as i tested it, working absolutely error free - except this problems with visible, not filtered HTML-Tags.

Maybe it's only a problem with old symbian s60v5 phones ...

Without this issue 1.20 is in fact better (faster, more functions) than the very reliable 1.11.
Lots of thanks for your enormous work!

@ haddock: thanks for your very quick response, but i'am using now the 1.16, which works fine too.
Back to top
View user's profile Send private message
Nokianero



Joined: 04 Mar 2009
Posts: 176
Location: Madrid, España

PostPosted: Mon Mar 11, 2013 3:06 pm    Post subject: Reply with quote

kruch wrote:

...

Hola @nokianero, I have received multiple reports about camera problems in Android, I'll try to fix it in 1.2.1.



Ok, kruch. I'll be waiting for. Many thanks. Wink

_________________
LG Optimus L5 (E610) Android ICS 4.0.3 + TrekBuddy 1.2.1 en castellano (x2fer ver.)
Nokia N70+Freefon Gansirf 3-3+TrekBuddy 0.9.83 en español (castellano).
Back to top
View user's profile Send private message
kruch
Site Admin


Joined: 02 Jul 2006
Posts: 5665

PostPosted: Mon Mar 11, 2013 8:07 pm    Post subject: Reply with quote

Don Atorre wrote:
except this problems with visible, not filtered HTML-Tags.


This could work properly: http://www.trekbuddy.net/dev/2013-03-11/
Back to top
View user's profile Send private message
Don Atorre



Joined: 08 Apr 2010
Posts: 15

PostPosted: Mon Mar 11, 2013 10:39 pm    Post subject: Reply with quote

kruch wrote:

This could work properly: http://www.trekbuddy.net/dev/2013-03-11/


Thanks, in deed no more html-tags in GC descriptions.

I'm not sure, if in older versions the phone (s60v5) vibrated when changing backlight intensity, zooming in and out. Now it does.

It vibrates also when pressing the middle icon in the soft menu/icon bar on bottom) This icon (looks like a double triangle) seems now to have no other function than to vibrate.

This is noch critic, i'm very pleased with your top work. It should be just a help for possible bug-fixing.

Thanks!
Back to top
View user's profile Send private message
kruch
Site Admin


Joined: 02 Jul 2006
Posts: 5665

PostPosted: Mon Mar 11, 2013 11:22 pm    Post subject: Reply with quote

i'm not sure; Settings->Misc->power save should disable vibration feedback for most cases
Back to top
View user's profile Send private message
Don Atorre



Joined: 08 Apr 2010
Posts: 15

PostPosted: Tue Mar 12, 2013 4:40 pm    Post subject: Symbian s60v5 Nokia 5800XM Reply with quote

kruch wrote:
i'm not sure; Settings->Misc->power save should disable vibration feedback for most cases


No, a restart of the phone fixed the vibration issue. Why it helped? I don't know, it just works now.

But there is probably still another litte bug:
The toggle wpt name/cmt/none icon in the softmenu does not work correct. It toggles

==> name with cmt behind (in the background, both yellow textboxes at same time on same place)

==> to none (just a small yellow line, like an unfilled yellow text-field)
to ==> none.
Back to top
View user's profile Send private message
billy06



Joined: 01 Oct 2008
Posts: 434
Location: Lowestoft U.K

PostPosted: Tue Mar 12, 2013 7:51 pm    Post subject: Reply with quote

name/cmt toggles fine on the latest dev version on my 5800
_________________
Nexus 5X, Nexus 5, Nexus 7 3G, HTC Sensation, nokia 5800. web:www.thetrekbuddies.co.uk . Twitter:http://twitter.com/TheTrekbuddies
Back to top
View user's profile Send private message Visit poster's website
yearling



Joined: 18 Apr 2007
Posts: 285

PostPosted: Tue Mar 12, 2013 9:06 pm    Post subject: Reply with quote

There is a small bug in this version.
It is impossible to display all waypoints or trackpoints from file (ShowAll).
There are displayed only names of waypoints but not waypoints (Navigation > Waypoints > ShowAll) and there are displayed track instead of trackpoints (Navigation > Tracks > ShowAll).
V. 1.1.6 works OK on NOKIA C3-01.
Back to top
View user's profile Send private message
Don Atorre



Joined: 08 Apr 2010
Posts: 15

PostPosted: Wed Mar 13, 2013 8:16 pm    Post subject: Reply with quote

billy06 wrote:
name/cmt toggles fine on the latest dev version on my 5800


My 5800 doesn't with latest dev version http://www.trekbuddy.net/dev/2013-03-11/

The toggle is supposed to be a three way toggle
name->cmt->none(empty)
This is the way it worked in older versions.

The first toggle position showed in older versions a textbox with cache name an yellow box in the background right to the position-circle.
Now it shows in a double layers with yellow backgrounds the caches name (1. Layer) and the cmt-text in second layer. Both with yellow backgrounds right to the circle.

The second toggle positon showed in older versions the cmt-text with this yellow box in the background right to the circle. Without a cmt-text it showed only the position-circle.
Now there is the circle and a small yellow line with the height of this yellow box. But no text in it. This is why i think the box is empty. The text which should appear here is found in the second layer of the first toggle position. With no cmt-text in first toggle-position second layer, there is also no yellow line near the circle. I think the behavior of the second toggle positon indicates, that cmt-text is now connected to first toggle-position instead of the second.

Third and last toggle positon is like in older versions: only the circle, or none text.
Back to top
View user's profile Send private message
guest



Joined: 08 Oct 2006
Posts: 5014

PostPosted: Tue Mar 19, 2013 6:37 am    Post subject: Tomek Reply with quote

I miss the fast application of measurement distance from the point a to b
Present on the page geoportal.pl
http://images44.fotosik.pl/635/538573493c160935.jpg
You can add this options TrekBuddy application?
He writes in Polish.
I used google translate.
Back to top
View user's profile Send private message Visit poster's website
kruch
Site Admin


Joined: 02 Jul 2006
Posts: 5665

PostPosted: Tue Mar 19, 2013 8:12 pm    Post subject: Reply with quote

yearling wrote:
There is a small bug in this version.
It is impossible to display all waypoints or trackpoints from file (ShowAll).
There are displayed only names of waypoints but not waypoints (Navigation > Waypoints > ShowAll) and there are displayed track instead of trackpoints (Navigation > Tracks > ShowAll).


Could you send me sample gpx for the first issue (only names but not waypoints)?

As for displaying trackpoints, maybe we need two ShowXXX commands, one for displaying gpx with ignoring the structure (pre-1.2 old style) and one that respects it. Or an option to force drawing point icon for points that are not part of active navigation route (ie. trackpoints)... ?
Back to top
View user's profile Send private message
guest



Joined: 08 Oct 2006
Posts: 5014

PostPosted: Sat Mar 30, 2013 9:59 am    Post subject: HTML-tag problem also with LG GT505 Reply with quote

Don Atorre wrote:
@ kruch:
the 1.20 is, as far as i tested it, working absolutely error free - except this problems with visible, not filtered HTML-Tags.

Maybe it's only a problem with old symbian s60v5 phones ...


Hi,

I got also an HTML tag problem with my LG GT505 phone in the GC long description section. The current version converts the &lt; entity into ≤ instead of <. As a result all tags are shown in the text ...

Greetings
Chris
Back to top
View user's profile Send private message Visit poster's website
kruch
Site Admin


Joined: 02 Jul 2006
Posts: 5665

PostPosted: Sat Mar 30, 2013 2:05 pm    Post subject: Reply with quote

It will be fixed in 1.2.1.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    TrekBuddy Forum Index -> Versions All times are GMT
Goto page Previous  1, 2, 3, 4  Next
Page 2 of 4

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group