Bílý vrch
icon TrekBuddy
www.trekbuddy.net
Outdoor companion.
  • internal / bluetooth / simulator GPS
  • offline raster maps
  • smart GPX / raw NMEA logs
  • waypoints and simple navigation
  • custom views
  • MIDP and Symbian phones
  • Blackberry
  • Android
Visit wiki to see all features, guides and howtos. Project tracker.

Partners:    (Polish/Polski)(Polski) Compass mapy      (Polish/Polski)(Polski) Galileos mapy      (Polish/Polski)(Polski) CartoMedia      (Czech/Èesky)(Èesky) Eaglesoft trasy      (Polish/Polski)(Polski) ExpressMap     

 FAQFAQ   SearchSearch   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
0.9.66
Goto page 1, 2, 3, 4, 5  Next
 
Post new topic   Reply to topic    TrekBuddy Forum Index -> Recycle Bin
View previous topic :: View next topic  
Author Message
kruch
Site Admin


Joined: 02 Jul 2006
Posts: 5662

PostPosted: Tue Oct 23, 2007 9:21 am    Post subject: 0.9.66 Reply with quote

Changelog
    - new navigation arrow (naviws.png; customizable) and course arrow are shown together (course arrow is rendered first)
    - new variables in CMS: spd.i,spd.i-avg,spd.i-avg-auto,spd.i-max, wpt-alt
    - altitude field added to wpt form
    - last-used cms profile loaded first
    - fix: {sat} refresh
    - fix: sound/alarm is played for single wpt and last wpt in route too
    - fix: capture format settings is editable
    - fix: GPX dt, ds appearance
    - fix: GoTo on wpt puts TB into browsing mode


0.9.66 download link
Requirements Installation Configuration

Update 2007-10-23 23:20 CET
Hotfix update. New limitation discovered for SonyEricsson JP-5 devices (K750i, K600, W800) - list can contain max 255 items. Applies to: file browser, waypoints lists.
    - NMEA parser improved to handle data without GGA sentence
    - fixed: XML parser (for CMS profiles degree sign)
    - fixed: event failures when no cms profiles were found

0.9.66 patch1 download link

Update 2007-10-25 21:00 CET
Patch update.
    - fixed: NMEA parser
    - fixed: structure settings for J9 version
    - fixed: event failures
    - fixed: "wpt reached" sound played forever

0.9.66 patch2 download link

Attached you may find navigation arrow in different colour. Just copy it as naviws.png to resources folder in DataDir if you want different colour.



naviws-blue.png
 Description:
navigation arrow - blue
 Filesize:  5.75 KB
 Viewed:  34887 Time(s)

naviws-blue.png



naviws-red.png
 Description:
navigation arrow - red
 Filesize:  5.75 KB
 Viewed:  34887 Time(s)

naviws-red.png



naviws-pink.png
 Description:
navigation arrow - purple
 Filesize:  5.69 KB
 Viewed:  34887 Time(s)

naviws-pink.png




Last edited by kruch on Thu Oct 25, 2007 7:11 pm; edited 5 times in total
Back to top
View user's profile Send private message
velman



Joined: 17 Oct 2007
Posts: 9

PostPosted: Tue Oct 23, 2007 9:30 am    Post subject: Reply with quote

Hi,

I'm sorry to say it, but the Dt and Ds option does not work on W810. The whole location-menu is a mess right now. It's the same problem as before but five times worse...

I'll post a picture soon.

Regards,
Staffan
Back to top
View user's profile Send private message
kruch
Site Admin


Joined: 02 Jul 2006
Posts: 5662

PostPosted: Tue Oct 23, 2007 10:15 am    Post subject: Reply with quote

Sad

EDIT: I removed layout directives in the attached version ,could you try it?

EDIT: attachments removed


Last edited by kruch on Wed Oct 24, 2007 9:46 pm; edited 1 time in total
Back to top
View user's profile Send private message
wowi



Joined: 23 Mar 2007
Posts: 78
Location: Munich

PostPosted: Tue Oct 23, 2007 1:02 pm    Post subject: Reply with quote

Very Happy Thankyou kruch, everything looks great! the two arrows are really cool!
Back to top
View user's profile Send private message
guest



Joined: 08 Oct 2006
Posts: 4880

PostPosted: Tue Oct 23, 2007 1:07 pm    Post subject: Reply with quote

where can i find a complete list of all cms variables?
Back to top
View user's profile Send private message Visit poster's website
guest



Joined: 08 Oct 2006
Posts: 4880

PostPosted: Tue Oct 23, 2007 1:35 pm    Post subject: Re: 0.9.66 Reply with quote

kruch wrote:
    - fix: GoTo on wpt puts TB into browsing mode
Could browsing mode also display the name(s) of POI(s)/wpt(s) in the map? Rolling Eyes
Back to top
View user's profile Send private message Visit poster's website
velman



Joined: 17 Oct 2007
Posts: 9

PostPosted: Tue Oct 23, 2007 2:44 pm    Post subject: Reply with quote

Hi again!

It works fine now. Thanks!

Here is a picture of what i looked like before:
(you may remove the picture if you want as it is quite large...

Regards,
Staffan

<picture removed>
Back to top
View user's profile Send private message
excite



Joined: 28 Sep 2007
Posts: 3

PostPosted: Tue Oct 23, 2007 3:16 pm    Post subject: ° Reply with quote

U teto verze (narozdil od minule) mi v cms trekbuddy zobrazi ° jako °, ale predtim A se striskou (soubor v UTF-8, v minule verzi vse normalne).
Trochu OT, ale jak nadradit napr. {course}° pomoci {0x1E}? Dve {}{} po sobe mi vraci stejnou hodnotu do obou (cili {course}{0x1E} je jako {course}{course}, to same napr. u <value>{spd-avg}/{spd-max}</value> vraci {spd-avg}/{spd-avg}.
Back to top
View user's profile Send private message
kruch
Site Admin


Joined: 02 Jul 2006
Posts: 5662

PostPosted: Tue Oct 23, 2007 3:48 pm    Post subject: Reply with quote

@excite Ajaj... no zkus ten soubor ulozit opravdu v UTF-8, tohle vypada jako ze sice je v deklaraci encoding="UTF-8", ale je to plain text (nezacina - v hexa - FF FE ...). Podivam se na to, asi to vratim zpatky, delal jsem tam tuhle zmenu, ze kdyz se zjisti, ze soubor neni skutecne UTF-8 encoded, deklarace se ignoruje...
{0x1E} je naprd, bohuzel dvakrat {} v jednom poli neni podporovany... Sad
Back to top
View user's profile Send private message
Petr



Joined: 16 Oct 2007
Posts: 9

PostPosted: Tue Oct 23, 2007 4:40 pm    Post subject: Reply with quote

Nechci otravovat s maličkostma ale možná malinkej návrh:
1. změnit tu zelenou šipku ("naviws.png") na jinou barvu protože když přepnu #kem do HPS tak se ta zelená šipka maskuje v těch zelenejch kroužkách.

2. V CMS to ukazuje přesnější rychlost na desetiny ale leze mi to z displeje stačí když upravím "font.72px.png" a nejsem si jistej jetly to neukazuje jen do 99.9Km/h pač moje služební autí fakt z kopce víc jak 110 nechtělo.
Back to top
View user's profile Send private message
druzicka



Joined: 07 Aug 2007
Posts: 90

PostPosted: Tue Oct 23, 2007 5:22 pm    Post subject: Reply with quote

Nesela by vychozi konfigurace ulozit na kartu a pak po preinstalovani ji nacist z karty? V linuxu musim predchozi verzi smazat a pak musim vse znovu nastavovat.
Back to top
View user's profile Send private message
x2fer



Joined: 31 Jan 2007
Posts: 1662
Location: Madrid, Spain

PostPosted: Tue Oct 23, 2007 6:15 pm    Post subject: Reply with quote

Please. let's support this thread in English... I do not understand anything, and it can be important for all.

Where is the mistake? ... {spd-avg} can never be major than {spd-svg-auto}.



Calculating the value of {spd-avg}, with this time and this distance, I obtain 20,08 Km/h. The value of {spd-avg-auto} is correct, 20,37 Km/h.

_________________
Sony Xperia M4 Aqua || N500 || C5-03 + BT-Q810 + TrekBuddy 1.33 (Español)
Back to top
View user's profile Send private message Visit poster's website
druzicka



Joined: 07 Aug 2007
Posts: 90

PostPosted: Tue Oct 23, 2007 6:26 pm    Post subject: Reply with quote

2 x2fer: my english is...ehm... but,

If I installing new version in linux I must delete old version from phone and all configuration is deleted too. I want backup confoguration to phone card and when new version is run load config from this file.
Back to top
View user's profile Send private message
x2fer



Joined: 31 Jan 2007
Posts: 1662
Location: Madrid, Spain

PostPosted: Tue Oct 23, 2007 6:41 pm    Post subject: Reply with quote

Sorry I´m not sure that it´s a bug ... I have had a problem with the XML files .. on having reinstated TB, quite correctly.
_________________
Sony Xperia M4 Aqua || N500 || C5-03 + BT-Q810 + TrekBuddy 1.33 (Español)


Last edited by x2fer on Wed Oct 24, 2007 8:50 am; edited 2 times in total
Back to top
View user's profile Send private message Visit poster's website
guest



Joined: 08 Oct 2006
Posts: 4880

PostPosted: Tue Oct 23, 2007 7:31 pm    Post subject: Reply with quote

Hello,
Nokia N95 and internal GPS won't work for me:
When starting GPS it displays "Failed to start provider [Internal]:api.location.LocationException:java.lang.SecurityException:Permission = javax.microedition.location.Location".
That is the same behavior as with v. 0.9.63 which i used previously. Back when installing 0.9.63 i found in this forum the hint to change MIDlet-Permissions-Opt to MIDlet-Permissions in the JAD-file. That helped for the old version.
Applying this change now results in the following behaviour: When starting GPS it displays "_EVENT FAILURE_(code 9;result '0';throwable null):java.lang.NullPointerException: 0". Then, after a sat fix is acquired (bulb switches from orange to green) the following is displayed every second or so: "_EVENT FAILURE_(code 10;result 'm@f426a459';throwable null):java.lang.IllegalStateException: NPE in view #2".

Carrier branded device (O2 Germany), firmware 11.0.026.
TB is installed on drive E (SD-Card) and so was the old version if i remember right.

Maybe someone has a hint to get this nice software run again on my phone? Thanx in advance.
Anon
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    TrekBuddy Forum Index -> Recycle Bin All times are GMT
Goto page 1, 2, 3, 4, 5  Next
Page 1 of 5

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group