Bílý vrch
icon TrekBuddy
www.trekbuddy.net
Outdoor companion.
  • internal / bluetooth / simulator GPS
  • offline raster maps
  • smart GPX / raw NMEA logs
  • waypoints and simple navigation
  • custom views
  • MIDP and Symbian phones
  • Blackberry
  • Android
Visit wiki to see all features, guides and howtos. Project tracker.

Partners:    (Polish/Polski)(Polski) Compass mapy      (Polish/Polski)(Polski) Galileos mapy      (Polish/Polski)(Polski) CartoMedia      (Czech/Èesky)(Èesky) Eaglesoft trasy      (Polish/Polski)(Polski) ExpressMap     

 FAQFAQ   SearchSearch   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
480 x 800 theme
Goto page Previous  1, 2, 3  Next
 
Post new topic   Reply to topic    TrekBuddy Forum Index -> Themes
View previous topic :: View next topic  
Author Message
Marcjet



Joined: 17 Feb 2011
Posts: 3

PostPosted: Wed Jun 15, 2011 8:32 pm    Post subject: Reply with quote

Hi gisela,

first i want to say thanks. this is a great theme. And it is the first one working properly with samsung jet. On all other 480x800 thenes the km counter started to count very rapidly although i was just walking and ended up with a few million km within a few minutes (or maybe i walk to fast;)

anyway, what is the difference between cms.gisela.d and cms.gisela.t? Did i miss something? I still get incorrect values for km/h(after few minutes walking like 1500km/h) in the upper left corner(green gauge) in cms.gisela.d....what could be the problem? may i just delete cms.gisela.d from the jet and only use cms.gisela.t then?
Back to top
View user's profile Send private message
gisela



Joined: 01 Nov 2007
Posts: 112
Location: Utrecht, Holland

PostPosted: Wed Jun 15, 2011 8:53 pm    Post subject: Reply with quote

Marcjet wrote:
Hi gisela,

first i want to say thanks. this is a great theme. And it is the first one working properly with samsung jet. On all other 480x800 thenes the km counter started to count very rapidly although i was just walking and ended up with a few million km within a few minutes (or maybe i walk to fast;)

Thanks!
I'm happy you enjoy it.

If you use trekbuddy with an internal gps, there is something wrong with the calculation of the distance. The theme calculates a new distance, based on speed, that is closer to reality.
I didn't feel like recalculating the time you are moving, so the average-moving speed is still a ridiculous number.
You can change this in cms.gisela.d by replacing
Code:
        <area x="150" y="100" w="97" h="43" font="digibig" align="right">
            <value>{spd.i-avg-auto}.</value>
        </area>
        <area x="223" y="100" w="22" h="23" font="digismall" align="left">
            <value>{spd.d-avg-auto}</value>
        </area>

with
Code:
        <area x="150" y="100" w="97" h="43" font="digibig" align="right">
            <value>{spd.i-avg}.</value>
        </area>
        <area x="223" y="100" w="22" h="23" font="digismall" align="left">
            <value>{spd.d-avg}</value>
        </area>

I use notepad to change those files.
Quote:
anyway, what is the difference between cms.gisela.d and cms.gisela.t? Did i miss something? I still get incorrect values for km/h(after few minutes walking like 1500km/h) in the upper left corner(green gauge) in cms.gisela.d....what could be the problem? may i just delete cms.gisela.d from the jet and only use cms.gisela.t then?

In cms.gisela.d the graphs have distance on the horizontal axis and the average speed is moving average speed.
In cms.gisela.t the graphs have time on the horizontal axis and the average speed is overal average speed.
There only is a difference between the two if there is difference in your speed, for instance if you're cycling in hilly areas. If you're not interested in one of the two you can of course delete one of them, it might even make it faster.

Gisela
Back to top
View user's profile Send private message
Marcjet



Joined: 17 Feb 2011
Posts: 3

PostPosted: Wed Jun 15, 2011 9:25 pm    Post subject: Reply with quote

thanks for your fast reply. i will try it with the new code tomorow. by the way, are you using the jet as well? in the new version 1.0.12 released today there seems to be real compass support for those phones with real compass. Jet has one, but i thought there is now way(except for route66) to access it, would be sweet if that works for the cms compass as well:)
Back to top
View user's profile Send private message
Roana



Joined: 28 Aug 2008
Posts: 9

PostPosted: Wed Aug 03, 2011 12:45 am    Post subject: Reply with quote

Hi Gisela!

Thanks for the theme!

I get some funny rhombus shaped signs in the graphics on my galaxy I9000 which appear and disappear in no predictable way but very often.

Maybe it is a characterset problem?

Any idea?

regards
Ulrike
Back to top
View user's profile Send private message
gisela



Joined: 01 Nov 2007
Posts: 112
Location: Utrecht, Holland

PostPosted: Wed Aug 03, 2011 7:54 am    Post subject: Reply with quote

Roana wrote:
Hi Gisela!

Thanks for the theme!

I get some funny rhombus shaped signs in the graphics on my galaxy I9000 which appear and disappear in no predictable way but very often.

Maybe it is a characterset problem?

Any idea?

regards
Ulrike


Hi Ulrike,

I'm glad you like the theme!
I've never seen this behaviour, maybe it has something to do with the charactersets, I would think maybe with font.gisela.mean.png.
But if you can tell me where they appear, it might tell me what causes it.

Gisela
Back to top
View user's profile Send private message
Roana



Joined: 28 Aug 2008
Posts: 9

PostPosted: Wed Aug 10, 2011 3:14 pm    Post subject: Reply with quote

gisela wrote:

Hi Ulrike,

I'm glad you like the theme!
I've never seen this behaviour, maybe it has something to do with the charactersets, I would think maybe with font.gisela.mean.png.
But if you can tell me where they appear, it might tell me what causes it.


They appear in the area of the graphs of speed and height. I think also it's a charset or maybe a display logic problem. They look like some non displayable characters.

I will try to take some photographs of them...
Back to top
View user's profile Send private message
lucamiravalle



Joined: 31 Jul 2011
Posts: 1

PostPosted: Thu Aug 11, 2011 1:07 pm    Post subject: Reply with quote

hi Gisela!!!!!

Your theme it's so awesome!!!!!!!

I have a problem. Whit tb 1.0.18, on my s8000 jet, the average speed dont work.

any solution???
Back to top
View user's profile Send private message
gisela



Joined: 01 Nov 2007
Posts: 112
Location: Utrecht, Holland

PostPosted: Sun Aug 21, 2011 6:49 pm    Post subject: Reply with quote

Roana wrote:
They appear in the area of the graphs of speed and height. I think also it's a charset or maybe a display logic problem. They look like some non displayable characters.

I will try to take some photographs of them...


If they only show in the speed graph, it could be the lines meant to indicate average and current speed. You can delete these from the cms.
If they also show in the altitude graph, I have no idea, unfortunately...

Gisela
Back to top
View user's profile Send private message
gisela



Joined: 01 Nov 2007
Posts: 112
Location: Utrecht, Holland

PostPosted: Sun Aug 21, 2011 6:51 pm    Post subject: Reply with quote

@lucamiravalle
Thanks for your compliments!
I'll try to make the average speed working.

Gisela
Back to top
View user's profile Send private message
gisela



Joined: 01 Nov 2007
Posts: 112
Location: Utrecht, Holland

PostPosted: Wed Aug 31, 2011 11:08 pm    Post subject: Reply with quote

gisela wrote:
Roana wrote:
They appear in the area of the graphs of speed and height. I think also it's a charset or maybe a display logic problem. They look like some non displayable characters.

I will try to take some photographs of them...


If they only show in the speed graph, it could be the lines meant to indicate average and current speed. You can delete these from the cms.
If they also show in the altitude graph, I have no idea, unfortunately...

Gisela


I found out what happens, it is because one of the characters (°) doesn't 'work'.
I'm trying to find a solution, maybe someone else knows how to solve this?
If one of the hecl-variables contains °, TB returns a strange questionmark.
Back to top
View user's profile Send private message
tenelord



Joined: 31 Mar 2011
Posts: 31

PostPosted: Fri Sep 30, 2011 10:59 pm    Post subject: Reply with quote

What does this do? set gisela::dt
Back to top
View user's profile Send private message
gisela



Joined: 01 Nov 2007
Posts: 112
Location: Utrecht, Holland

PostPosted: Sat Oct 01, 2011 3:34 pm    Post subject: Reply with quote

tenelord wrote:
What does this do? set gisela::dt

It sets the initial time interval for the graph.
Back to top
View user's profile Send private message
tenelord



Joined: 31 Mar 2011
Posts: 31

PostPosted: Sat Oct 01, 2011 4:30 pm    Post subject: Reply with quote

Is there any way to turn off some variables so they do not use processor? I would like to have only altitude Δd graph and direction arrows.
Back to top
View user's profile Send private message
gisela



Joined: 01 Nov 2007
Posts: 112
Location: Utrecht, Holland

PostPosted: Sat Oct 01, 2011 9:35 pm    Post subject: Reply with quote

tenelord wrote:
Is there any way to turn off some variables so they do not use processor? I would like to have only altitude Δd graph and direction arrows.

it's the drawing of the graphs that's complicated. I created a version of gisela.hcl with just one graph. Unfortunately, I can't post it, I'll try again later...

the easiest way to reduce processor use is to delete every instance of gisela::drawtime.


Gisela
Back to top
View user's profile Send private message
tenelord



Joined: 31 Mar 2011
Posts: 31

PostPosted: Sat Oct 01, 2011 9:41 pm    Post subject: Reply with quote

It would be great if you could upload it.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    TrekBuddy Forum Index -> Themes All times are GMT
Goto page Previous  1, 2, 3  Next
Page 2 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group