Bílý vrch
icon TrekBuddy
www.trekbuddy.net
Outdoor companion.
  • internal / bluetooth / simulator GPS
  • offline raster maps
  • smart GPX / raw NMEA logs
  • waypoints and simple navigation
  • custom views
  • MIDP and Symbian phones
  • Blackberry
  • Android
Visit wiki to see all features, guides and howtos. Project tracker.

Partners:    (Polish/Polski)(Polski) Compass mapy      (Polish/Polski)(Polski) Galileos mapy      (Polish/Polski)(Polski) CartoMedia      (Czech/Èesky)(Èesky) Eaglesoft trasy      (Polish/Polski)(Polski) ExpressMap     

 FAQFAQ   SearchSearch   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
0.9.81
Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8, 9  Next
 
Post new topic   This topic is locked: you cannot edit posts or make replies.    TrekBuddy Forum Index -> Recycle Bin
View previous topic :: View next topic  
Author Message
Michal.K



Joined: 25 Apr 2008
Posts: 312
Location: Czech / Slovak republic

PostPosted: Tue Aug 26, 2008 11:31 am    Post subject: Reply with quote

New fuction in TB 0.9.81 are great, but I have problem with time in waypoint names => at 12:52 i was record waypoint and waypoint name is "wgps-20080826-104938". ???
(CZ: Problem s názvem bodú. Po naistalováni TB 0.9.81 nastal problém s časem-body i trasu ukládá o 2h a něco dřív => ve 12:52 jsem uložil bod a název bodu je "wgps-20080826-104938".
Nevíte čím by to mohlo být? Doteď takej problém jsem neměl. Zkoušel jsem i preinstalovat TB a nic.

_________________
HTC Sensation XE a obcas SE K850i + Evolve GoTraxx
Back to top
View user's profile Send private message
druzicka



Joined: 07 Aug 2007
Posts: 90

PostPosted: Tue Aug 26, 2008 11:50 am    Post subject: Reply with quote

David.G wrote:
New fuction in TB 0.9.81 are great, but I have problem with time in waypoint names => at 12:52 i was record waypoint and waypoint name is "wgps-20080826-104938". ???
(CZ: Problem s názvem bodú. Po naistalováni TB 0.9.81 nastal problém s časem-body i trasu ukládá o 2h a něco dřív => ve 12:52 jsem uložil bod a název bodu je "wgps-20080826-104938".
Nevíte čím by to mohlo být? Doteď takej problém jsem neměl. Zkoušel jsem i preinstalovat TB a nic.


IMHO is first time from your phone and second time from your gps. phone is in SELC time and GPS is in GMT. And minutes difference is wrong time in phone Surprised)

CZ: Podlem ne program jednou cas bere z telefonu a jednou z GPS. roszil 2 hodin odpovida StredoEvropskemuLetnimuCasu a ty minuty budou nepresnym nastavenim casu v telefonu.
Back to top
View user's profile Send private message
kruch
Site Admin


Joined: 02 Jul 2006
Posts: 5664

PostPosted: Tue Aug 26, 2008 1:38 pm    Post subject: Reply with quote

English only! Twisted Evil

Last edited by kruch on Tue Aug 26, 2008 1:40 pm; edited 1 time in total
Back to top
View user's profile Send private message
kruch
Site Admin


Joined: 02 Jul 2006
Posts: 5664

PostPosted: Tue Aug 26, 2008 1:40 pm    Post subject: Reply with quote

yearling wrote:
There is a bug in working with WP.
If I delete one point from file (WPT02 in example) it finished correctly, close TB, start TB again and try to open this file so it is impossible - file is incorect.
Deleting WP damaged file. Look at example.


Thanks... yet another hotfix ahead for tonight Crying or Very sad
By the way it works ok on N6230i...
EDIT: no, it happens with file revisions option off
Back to top
View user's profile Send private message
kwicol



Joined: 16 Mar 2008
Posts: 105

PostPosted: Tue Aug 26, 2008 7:07 pm    Post subject: Reply with quote

Hi,

Is it possible add new variable to CMS, for next version?
I think about time to waypoint:
{wpt-t-dif} = {wpt-eta}- {time}
or
{wpt-t-dif} = {wpt-dist} / {spd-avg}

For me, will be better when I know, how long I will "go" to waypoin, in place of time arrive.
Back to top
View user's profile Send private message
FoG



Joined: 30 May 2008
Posts: 33
Location: España

PostPosted: Tue Aug 26, 2008 7:29 pm    Post subject: Reply with quote

Hi.
I've been trying the new version of TB this afternoon, and it had the same problem with the backlight, like in the previous version (not in "testing 0.9.81").
If you can, take a look on it.

I have a Nokia N70.

Thanks anyway.

P.S.: I'm always telling thank you!! maybe it's because I use TB a lot and I love it!! Wink
Back to top
View user's profile Send private message
lehti



Joined: 29 Jul 2008
Posts: 3
Location: Finland

PostPosted: Tue Aug 26, 2008 8:14 pm    Post subject: backlight control Reply with quote

hi,

When i'm changing backlight level (button 3), phone asks can it use network to sending & receiving ?!. After that pressing button has no effect to backlight level, but shows backlight percentages(%). Ver.0.9.80 was ok with this.
Phone is Nokia E51.
Back to top
View user's profile Send private message
kati42



Joined: 26 Aug 2008
Posts: 1

PostPosted: Tue Aug 26, 2008 8:31 pm    Post subject: Reply with quote

I'm using a CDMA HTC Touch (Sprint Vogue) updated to 6.1 (note: it's a touchscreen device, not smartphone edition) to unlock GPS capabilities. GPS works in Google Maps, Windows Live, etc. But my problem is not a GPS problem (yet).

I installed TB 0.9.81 by downloading the jad and jar files to my device and installing the jad file from there.

I'm having a problem running TB for the first time. I can "install" it, but I do *not* get prompted to create the DataDir.directory tree. I had manually created the directory tree on my storage card, but I'm not given a chance to select it.

When I run TB, I am prompted to allow TrekBuddy to read user data, to which I said Yes. A map flashes briefly, then I get an error screen that says 'DataDir' not accessible - please fix it: java.lang.SecurityException

I need to press the "dismiss" button something like 6 times (this may be a coincidence, and it's just that some time has to pass) to get back to the map screen. However, I only see the map for a brief instant, then I get another prompt asking about permissions to send/receive from //127.0.0.1:20175.

I say Yes, but then immediately get an error screen that says "A MIDlet thread threw an uncaught exception. Kill the MIDlet?"

Regardless of how many times I press either "resume" or "exit" (I've tried 10s of times), TB stays stuck there.

Other info: I am running GPSPort and had that working with mgmaps (I'm trying out my options). I'm using the Esmertec Jbed that comes with my device. Its build ID is 20080521.4.1v.

I have tried the "generic", "J9", and minimal versions of TB. For the generic and J9 I have tried OTA installation as well. For both I have also tried installing by "running" the .jad file in File Explorer and installing from within Jbed (I did uninstall between installations). Same result each time (except installing OTA I think didn't work at all - I wasn't keeping track at that point).

Any suggestions would be appreciated, thanks.
Back to top
View user's profile Send private message
kruch
Site Admin


Joined: 02 Jul 2006
Posts: 5664

PostPosted: Tue Aug 26, 2008 9:29 pm    Post subject: Reply with quote

FoG wrote:
and it had the same problem with the backlight, like in the previous version (not in "testing 0.9.81").


Backlight in 0.9.81 beta worked ok and in the final not?? And, I wonder, what do you see in Info->Technical->DeviceCtrl?
Back to top
View user's profile Send private message
kruch
Site Admin


Joined: 02 Jul 2006
Posts: 5664

PostPosted: Tue Aug 26, 2008 9:32 pm    Post subject: Re: backlight control Reply with quote

lehti wrote:
When i'm changing backlight level (button 3), phone asks can it use network to sending & receiving ?!. After that pressing button has no effect to backlight level, but shows backlight percentages(%). Ver.0.9.80 was ok with this. Phone is Nokia E51.


Backlight control in 0.9.81 on S60 3rd expects a native helper application running, see http://wiki.trekbuddy.net/index.php/Tools.
Back to top
View user's profile Send private message
kruch
Site Admin


Joined: 02 Jul 2006
Posts: 5664

PostPosted: Tue Aug 26, 2008 10:05 pm    Post subject: Reply with quote

@kati42

I think I (more or less) know what is happening. I suggest that you set permissions to allow the midlet to Always read (and write) user data to avoid the prompts. Then start TB, go through the boot process, dismiss the "DataDir not accessible..." dialog. A world map should get displayed, but no localhost:127.0.0.1 connection attempt should occur (you may have pressed the button too many times when you were answering the prompts andso you actually Start-ed tracking).

Then select Load Map to open a file browser. Now it would be great if you could tell me what filesystem roots you see, thanks. I think the default DataDir (Settings->Basic->DataDir) path is wrong for your setup; the default for WM device is file:///Storage%20Card/TrekBuddy/, but I suspect that on your device there is no such (Storage Card/) root for a memory card.
Back to top
View user's profile Send private message
FoG



Joined: 30 May 2008
Posts: 33
Location: España

PostPosted: Tue Aug 26, 2008 10:33 pm    Post subject: Reply with quote

kruch wrote:
Backlight in 0.9.81 beta worked ok and in the final not?? And, I wonder, what do you see in Info->Technical->DeviceCtrl?


DeviceCtrl
S60

I hope it will be useful for you (and for me!! hehe).

Bye.

P.S.: BTW, i didn't try 0.9.81 BETA, i was using a preliminary version of 0.9.81 that you released at the same time of the s60 helper application.
Back to top
View user's profile Send private message
Celda



Joined: 03 Jun 2008
Posts: 320
Location: CZ

PostPosted: Tue Aug 26, 2008 11:25 pm    Post subject: Reply with quote

I'm just testing this new version with HW described in my signature below.

First impressions:
* Working with WPTs in a GPX:
Much faster indeed, really able to browse faster by left/right arrow - SPAM Cool Exclamation

* The only negative (? bug) I've found so far (compared to 0.9.80):
TB does not make the typical sound neither when the comm status with GPS changes nor when selected WPT is reached Crying or Very sad
(I guessed this could have something in common with the settings of "Settings - Desktop - no sounds" and/or "Settings - Misc - power save" but no their combination seems to help.)

But as usual: the problem descibed above seems to be minor. Thank you for a marvellous application Exclamation

_________________
Čelda
Gigabyte GSmart G1355 (dual SIM, Android 2.3.4 Gingerbread)
Till 5/2012:
mobile: SAMSUNG SGH D880 Duos (dual SIM)
GPS: Qstarz BT-1200 Bluetooth Solar Travel Recorder (MTK chipset)
Back to top
View user's profile Send private message
Iron



Joined: 18 Jun 2008
Posts: 1

PostPosted: Wed Aug 27, 2008 4:30 am    Post subject: Reply with quote

Just noticed that Skandinavian letters are not usable in map names. At least letters Ä, ä, Ö, ö, Å here in Finland.

N95 in use.
Back to top
View user's profile Send private message
kruch
Site Admin


Joined: 02 Jul 2006
Posts: 5664

PostPosted: Wed Aug 27, 2008 8:46 pm    Post subject: Reply with quote

yearling wrote:
There is a bug in working with WP.
If I delete one point from file (WPT02 in example) it finished correctly, close TB, start TB again and try to open this file so it is impossible - file is incorect.
Deleting WP damaged file. Look at example.


Fixed and updated version uploaded.

@kati42 the updated version should work for you better too

@Celda with no sounds and powersave checked the phone will be quiet; but with powersave unchecked it should vibrate as before... Rolling Eyes
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   This topic is locked: you cannot edit posts or make replies.    TrekBuddy Forum Index -> Recycle Bin All times are GMT
Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8, 9  Next
Page 2 of 9

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group