Bílý vrch
icon TrekBuddy
www.trekbuddy.net
Outdoor companion.
  • internal / bluetooth / simulator GPS
  • offline raster maps
  • smart GPX / raw NMEA logs
  • waypoints and simple navigation
  • custom views
  • MIDP and Symbian phones
  • Blackberry
  • Android
Visit wiki to see all features, guides and howtos. Project tracker.

Partners:    (Polish/Polski)(Polski) Compass mapy      (Polish/Polski)(Polski) Galileos mapy      (Polish/Polski)(Polski) CartoMedia      (Czech/Èesky)(Èesky) Eaglesoft trasy      (Polish/Polski)(Polski) ExpressMap     

 FAQFAQ   SearchSearch   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
0.9.63
Goto page 1, 2, 3  Next
 
Post new topic   Reply to topic    TrekBuddy Forum Index -> Recycle Bin
View previous topic :: View next topic  
Author Message
kruch
Site Admin


Joined: 02 Jul 2006
Posts: 5663

PostPosted: Sat Sep 15, 2007 4:29 pm    Post subject: 0.9.63 Reply with quote

A few bugfixes...

Changelog
    - custom datums may now be stored in file (see Customization in wiki)
    - scale showing may be turned on/off (Setting->Desktop->OSD scale)
    - fixed weird waypoints listing behaviour on some SE phones
    - fixed image saving for waypoints (they were not saved in previous version)
    - fixed {dist-t} value in CMS
    - fixed location SMS reception

0.9.63 download link
Requirements Installation Configuration


Last edited by kruch on Sat Sep 15, 2007 9:25 pm; edited 5 times in total
Back to top
View user's profile Send private message
krzysiekz



Joined: 07 Oct 2006
Posts: 168

PostPosted: Sat Sep 15, 2007 6:14 pm    Post subject: Reply with quote

{dist-t} now only shows 0.0 :(
Back to top
View user's profile Send private message
kruch
Site Admin


Joined: 02 Jul 2006
Posts: 5663

PostPosted: Sat Sep 15, 2007 7:08 pm    Post subject: Reply with quote

Works for me... Shocked Could you send me your cms.simple.xml?
Back to top
View user's profile Send private message
krzysiekz



Joined: 07 Oct 2006
Posts: 168

PostPosted: Sat Sep 15, 2007 7:30 pm    Post subject: Reply with quote

Something is wrong, but i don't know what. I tried 2 different nmea logs, with first dist-t works, with second shows 0.0. I'll try tomorrow with gps if it works or not. I sent you those 2 logs and cms.
Back to top
View user's profile Send private message
Ranger



Joined: 12 Dec 2006
Posts: 6030

PostPosted: Sat Sep 15, 2007 8:20 pm    Post subject: Reply with quote

Wrong time on map screen ?
I compared it with correctly shown time on CMS.



Time_error.png
 Description:
 Filesize:  22.24 KB
 Viewed:  33106 Time(s)

Time_error.png


Back to top
View user's profile Send private message
kruch
Site Admin


Joined: 02 Jul 2006
Posts: 5663

PostPosted: Sat Sep 15, 2007 8:49 pm    Post subject: Reply with quote

@krzysiekz thanks for your logs - I got a bug in distance calculation; fixed and updated version uploaded - now it is marked as 0.9.63

@Ranger do you happen to have nmea log? I could not reproduce it...
Back to top
View user's profile Send private message
Ranger



Joined: 12 Dec 2006
Posts: 6030

PostPosted: Sat Sep 15, 2007 9:00 pm    Post subject: Reply with quote

Yes, I tested it with few TB nmea logs from last months, both in emu and phone. Pls find one of them attached.

EDIT
I tried new one 0963 version and first log works Rolling Eyes
But check next ones ...

CASE CLOSED


Last edited by Ranger on Sun Sep 16, 2007 4:31 pm; edited 1 time in total
Back to top
View user's profile Send private message
kruch
Site Admin


Joined: 02 Jul 2006
Posts: 5663

PostPosted: Sat Sep 15, 2007 11:12 pm    Post subject: Reply with quote

Interesting testcases... fixed, and updated version silently uploaded. Confused
Back to top
View user's profile Send private message
alcorc



Joined: 21 Oct 2006
Posts: 8

PostPosted: Sun Sep 16, 2007 11:27 am    Post subject: can not load atlas Reply with quote

hi kruch.
i have problem in trekbuddy 0.9.61 and newer.
I cant load atlas. (non tared).
mistake text: (3) null: java.util.nosuchelementexception

phone: K750i
Back to top
View user's profile Send private message
Ranger



Joined: 12 Dec 2006
Posts: 6030

PostPosted: Sun Sep 16, 2007 11:50 am    Post subject: Reply with quote

One more problematic case Sad

CASE CLOSED


Last edited by Ranger on Sun Sep 16, 2007 4:32 pm; edited 1 time in total
Back to top
View user's profile Send private message
kruch
Site Admin


Joined: 02 Jul 2006
Posts: 5663

PostPosted: Sun Sep 16, 2007 2:55 pm    Post subject: Re: can not load atlas Reply with quote

alcorc wrote:
mistake text: (3) null: java.util.nosuchelementexception


Please find which map is causing the problem (load one by one) and send me .map and .set files.
Back to top
View user's profile Send private message
kruch
Site Admin


Joined: 02 Jul 2006
Posts: 5663

PostPosted: Sun Sep 16, 2007 2:57 pm    Post subject: Reply with quote

@Ranger both on map and cms screen I can see time going 12:23-12:4x ok... ? (in the emu)
Back to top
View user's profile Send private message
Ranger



Joined: 12 Dec 2006
Posts: 6030

PostPosted: Sun Sep 16, 2007 3:21 pm    Post subject: Reply with quote

I have done hard reset of my notebook, cleared emu database and tried again. And it works well with this log now.
What the hell Twisted Evil
I found, that start time in map mode was random for some logs, just give me a little more time to be 100% sure Embarassed
Time from 12:23 is exact, I saw it like 15:34 on map earlier Shocked



Time_OK.png
 Description:
 Filesize:  23.54 KB
 Viewed:  32649 Time(s)

Time_OK.png


Back to top
View user's profile Send private message
alcorc



Joined: 21 Oct 2006
Posts: 8

PostPosted: Sun Sep 16, 2007 5:00 pm    Post subject: i have found the mistake Reply with quote

gmi file contained few rows below coordinates.
Here is the file:



D15.txt
 Description:
gmi file with free rows below coordinates

Download
 Filename:  D15.txt
 Filesize:  247 Bytes
 Downloaded:  142 Time(s)

Back to top
View user's profile Send private message
kruch
Site Admin


Joined: 02 Jul 2006
Posts: 5663

PostPosted: Sun Sep 16, 2007 5:34 pm    Post subject: Reply with quote

Yes, empty lines are the problem, it is a bug in newer TB.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    TrekBuddy Forum Index -> Recycle Bin All times are GMT
Goto page 1, 2, 3  Next
Page 1 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group