Bílý vrch
icon TrekBuddy
www.trekbuddy.net
Outdoor companion.
  • internal / bluetooth / simulator GPS
  • offline raster maps
  • smart GPX / raw NMEA logs
  • waypoints and simple navigation
  • custom views
  • MIDP and Symbian phones
  • Blackberry
  • Android
Visit wiki to see all features, guides and howtos. Project tracker.

Partners:    (Polish/Polski)(Polski) Compass mapy      (Polish/Polski)(Polski) Galileos mapy      (Polish/Polski)(Polski) CartoMedia      (Czech/Èesky)(Èesky) Eaglesoft trasy      (Polish/Polski)(Polski) ExpressMap     

 FAQFAQ   SearchSearch   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
Crash when zooming quickly. B2710

 
Post new topic   Reply to topic    TrekBuddy Forum Index -> Bugs
View previous topic :: View next topic  
Author Message
fanfanlatulipe26



Joined: 26 Dec 2015
Posts: 5
Location: France

PostPosted: Sat Dec 26, 2015 11:49 am    Post subject: Crash when zooming quickly. B2710 Reply with quote

First of all: congratulation for this very nice application. Well done Wink
I ran into a problem when zooming.
I am using a SAMSUNG B2710. with TrekBuddy 1.3, french version, and TrekBuddy tared atlas.
In "Menu/Settings/Misc" I selected "Lowmem I/O"

When zooming quickly in with the key "9", TB crashes giving a lot of messages like the following:
_EVENT FAILURE_ (code 10;result 'am@xxxxxx';throwable null); api.lang.RuntimeException: Error in [location updated] in view #0 Caused by: java.lang.NullPointerException : 0

where the part xxxxx changes in each message (address ?). The only way I found to get out of the crash is to stop TB with the hang up / end key
It seems to occur with rather large maps, mainly high zoom level (my level 15 is 66Mb and 16th is 202mb), maybe when you press the 9th key before TB displays the map level and settle down.
The same occurs when zooming down quickly

A similar crash occur when zooming quickly even if the GPS itself is not running . Message is:
Impossible d'utiliser la carte:
java.lang.NullPointerException: 0
Back to top
View user's profile Send private message
boowoo



Joined: 12 Jun 2013
Posts: 556
Location: France

PostPosted: Sat Dec 26, 2015 2:43 pm    Post subject: Reply with quote

I've tested my B2710/TBv1.30 with your settings + big atlas (4Go) with no problems !
Could you check if you run it with these settings : (download the screenshots)
http://www.trekbuddy.net/forum/viewtopic.php?t=5289&postdays=0&postorder=asc&start=90
Back to top
View user's profile Send private message
fanfanlatulipe26



Joined: 26 Dec 2015
Posts: 5
Location: France

PostPosted: Sat Dec 26, 2015 3:45 pm    Post subject: Reply with quote

I used all the settings I found in the pictures: same crash.
My Atlas is 281Mo.
If I remember well I already got the same behavour with a different Atlas
Back to top
View user's profile Send private message
boowoo



Joined: 12 Jun 2013
Posts: 556
Location: France

PostPosted: Sat Dec 26, 2015 4:16 pm    Post subject: Reply with quote

Quote:
If I remember well I already got the same behavour with a different Atlas

It's necessary to be sure ... maybe the problem is because errors in your atlas ; you could try to make another one quickly with MOBAC.
Back to top
View user's profile Send private message
fanfanlatulipe26



Joined: 26 Dec 2015
Posts: 5
Location: France

PostPosted: Sat Dec 26, 2015 7:23 pm    Post subject: Reply with quote

I made a new atlas using the last release of MOBAC 2.0.0 beta 1 and got the same error.

The atlas includes zooom levels 10,11,12,13,14,15,16
Back to top
View user's profile Send private message
boowoo



Joined: 12 Jun 2013
Posts: 556
Location: France

PostPosted: Sat Dec 26, 2015 8:06 pm    Post subject: Reply with quote

Other ways ...
- Device problem (nothing to do)
- sd Card problem (low speed class) - I run TB with sd Card Class 10
- TB version with corrupt file (try another TB version to test)
Maybe someone have best idea ?
Back to top
View user's profile Send private message
fanfanlatulipe26



Joined: 26 Dec 2015
Posts: 5
Location: France

PostPosted: Sat Dec 26, 2015 9:40 pm    Post subject: Reply with quote

My card is a SanDisk 16mb class 4 ... I don't have a class 10 on hands but I'll try . It could be a timing problem ...
Back to top
View user's profile Send private message
boowoo



Joined: 12 Jun 2013
Posts: 556
Location: France

PostPosted: Sat Dec 26, 2015 10:31 pm    Post subject: Reply with quote

Samsung theoric limit for B2710 is 16 Gb, but i use TB with a Samsung SD Card 32 Gb class 10 for more than two years with no problem of memory or access and with atlas size 4 Go ...
Back to top
View user's profile Send private message
fanfanlatulipe26



Joined: 26 Dec 2015
Posts: 5
Location: France

PostPosted: Sun Dec 27, 2015 2:34 pm    Post subject: Reply with quote

I made the test with a new 16mb class 10 memory, with a new installation from scratch of TB 1.3.0 (new download) and get the same result.
In fact TB is running fine as long as I don't press twice in a row the zoom in key 9 when I reach high zoom levels. So I just need to control a bit my fingers Laughing
Back to top
View user's profile Send private message
boowoo



Joined: 12 Jun 2013
Posts: 556
Location: France

PostPosted: Sun Dec 27, 2015 3:01 pm    Post subject: Reply with quote

Quote:
In fact TB is running fine as long as I don't press twice in a row the zoom in key 9 when I reach high zoom levels. So I just need to control a bit my fingers

Yes, it works, but not normal ... really strange Rolling Eyes
I try many times but i'm not able to reproduce your problem ! Wink
Back to top
View user's profile Send private message
boowoo



Joined: 12 Jun 2013
Posts: 556
Location: France

PostPosted: Sun Jan 03, 2016 6:46 am    Post subject: Reply with quote

@fanfanlatulipe26

Try this beta version :
http://www.trekbuddy.net/dev/2015-08-31
It should fix your problem.
Work fine for me with two different B2710 ... Wink
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    TrekBuddy Forum Index -> Bugs All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group