Bílý vrch
icon TrekBuddy
www.trekbuddy.net
Outdoor companion.
  • internal / bluetooth / simulator GPS
  • offline raster maps
  • smart GPX / raw NMEA logs
  • waypoints and simple navigation
  • custom views
  • MIDP and Symbian phones
  • Blackberry
  • Android
Visit wiki to see all features, guides and howtos. Project tracker.

Partners:    (Polish/Polski)(Polski) Compass mapy      (Polish/Polski)(Polski) Galileos mapy      (Polish/Polski)(Polski) CartoMedia      (Czech/Èesky)(Èesky) Eaglesoft trasy      (Polish/Polski)(Polski) ExpressMap     

 FAQFAQ   SearchSearch   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
0.9.83
Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8, 9  Next
 
Post new topic   This topic is locked: you cannot edit posts or make replies.    TrekBuddy Forum Index -> Recycle Bin
View previous topic :: View next topic  
Author Message
Nokianero



Joined: 04 Mar 2009
Posts: 176
Location: Madrid, España

PostPosted: Thu Mar 12, 2009 9:44 am    Post subject: Re: ui-profile Reply with quote

billy06 wrote:
i see you have ui-profile as the first folder i have it as a second as it is in a trekbuddy folder on the root as in E:trekbuddy\ui-profiles\ i wonder if this changes things ? i will try to reproduce your proplem on my device hope this helps


I'm so sorry, billy06, it's a mistake Embarassed : I have got the same folder's level than you have, I would want to say that 'Set' folder is deeper than ui-profile one but really i have the same path than you: E:\Trekbuddy\ui-profile. Sorry again. Embarassed Embarassed

I hope when you see this post, you don't make changes on your phone yet. Wink

Thank you very much for your interest, billy06. Smile

Greetings from Nokia planet, 'earth-humans' Razz Razz Razz
Back to top
View user's profile Send private message
qwertgfdsa



Joined: 27 May 2008
Posts: 14

PostPosted: Thu Mar 12, 2009 4:40 pm    Post subject: Reply with quote

@Nokianero:

Have you tried hiding only the image files? Not the folder and not the xml file!

@kruch:
When a map can't be loaded, TrekBuddy should fall back to the built-in world map. I wanted to switch maps and accidentally deleted the old one before setting up the new one as default. Now TrekBuddy won't start (Init map: java.io.IOException), and I have to copy the old map back onto the phone... This might also be useful, when the memory card with the map is not inserted. So, leave the setting as is, but display the world map.
Back to top
View user's profile Send private message
billy06



Joined: 01 Oct 2008
Posts: 434
Location: Lowestoft U.K

PostPosted: Fri Mar 13, 2009 7:42 am    Post subject: deleted default map Reply with quote

to get round this you can press"#" key to goto the hps screen this stops the error flag from there you can load map Wink comes in very handy if you are in the field !
Back to top
View user's profile Send private message Visit poster's website
Nokianero



Joined: 04 Mar 2009
Posts: 176
Location: Madrid, España

PostPosted: Fri Mar 13, 2009 8:11 am    Post subject: Reply with quote

qwertgfdsa wrote:
@Nokianero:

Have you tried hiding only the image files? Not the folder and not the xml file!



Thx for your help, qwertgfdsa Smile , I tried it: CMS mode runs ok on TB, the images files are recognized and showed on screen, but in 'Gallery' too. Sad
They are going to no disappear in 'Gallery' ever more: Evil or Very Mad Brrrr !!! Evil or Very Mad

The problem is going on: It will have to take many patience with it. Wink

Greetings from Nokia planet, 'earth-humans'. Razz Razz Razz
Back to top
View user's profile Send private message
qwertgfdsa



Joined: 27 May 2008
Posts: 14

PostPosted: Fri Mar 13, 2009 9:23 am    Post subject: Reply with quote

Sorry nokianero, on a N82 it works that way! But, try this: Put the images in a subfolder of "ui-profiles", hide that folder and the files in it and then change the xml file so that it looks for the images in the subfolder. If that doesn't work I'm out of ideas.

Thanks billy06, that's a neat trick! You have to be quick though and press "OK" to get rid of the exception and then immediately press "#" before the next exception shows up. Smile
Back to top
View user's profile Send private message
Nokianero



Joined: 04 Mar 2009
Posts: 176
Location: Madrid, España

PostPosted: Fri Mar 13, 2009 11:09 am    Post subject: Reply with quote

qwertgfdsa wrote:
Sorry nokianero, on a N82 it works that way! But, try this: Put the images in a subfolder of "ui-profiles", hide that folder and the files in it and then change the xml file so that it looks for the images in the subfolder. If that doesn't work I'm out of ideas.


qwertgfdsa, are you telling me I change image files path into xml files? How is it? Shocked Can I open xml's on 'Wordpad' and so on, or Hex editor? Confused

In the other side, What edition nSeries is your N82, S60 2nd or 3rd?

Thx in advance.

Greetings from Nokia planet, 'earth-humans'. Razz Razz Razz
Back to top
View user's profile Send private message
qwertgfdsa



Joined: 27 May 2008
Posts: 14

PostPosted: Fri Mar 13, 2009 12:29 pm    Post subject: Reply with quote

N82 is S60, 3rd Edition.

And yes, xml files are plain text files, so open it in Wordpad, or any other text editor.

You should see a few lines like this (one for each image):
Code:
<font name="db_track" file="db_track.png" />

Change them to:
Code:
<font name="db_track" file="img/db_track.png" />

Then put all images in the "img" subfolder and hide them there like you did with the map folders.

I don't know if this works, I haven't tried it myself. Good luck!
Back to top
View user's profile Send private message
Nokianero



Joined: 04 Mar 2009
Posts: 176
Location: Madrid, España

PostPosted: Fri Mar 13, 2009 8:00 pm    Post subject: Reply with quote

qwertgfdsa wrote:

You should see a few lines like this (one for each image):
Code:
<font name="db_track" file="db_track.png" />

Change them to:
Code:
<font name="db_track" file="img/db_track.png" />

Then put all images in the "img" subfolder and hide them there like you did with the map folders.

I don't know if this works, I haven't tried it myself. Good luck!


Thank Godness!! Very Happy Very Happy
and, of course, Thank you very much, qwertgfdsa Wink , you are plenty of real solution !! Idea Idea

I did it all you told me, and... Eureka! It really works: No more png images in 'Gallery' and CMS runs ok ! Smile

I wish to thank to billy06 Wink and kruch Wink , for their uninteresting help too.

TB is great, CMS on TB is great, Kruch is greater but this forum is the greatest with persons like all of you... Cool

Greetings from Nokia planet, 'earth-humans'. Razz Razz Razz
Back to top
View user's profile Send private message
xvici



Joined: 29 Mar 2008
Posts: 6

PostPosted: Fri Apr 03, 2009 2:14 pm    Post subject: Timezones with daylight saving time Reply with quote

Hi Kruch,

I have recently upgraded to 0.9.83 (from .81) version and get problems with new time format in GPX log. The time itself is correct but the timezone not. I guess, that in central Europe during daylight saving time we have +02:00. But there is +01:00 in GPX logs. It brings some problems when processing logs in PC.

I have searched the discussion but haven't found similar posts.

Maybe it would be great to implement option in settings menu that everybody could choose what format to log.

Phone: SE K550i
Timezone in phone settings menu: +01:00
Summer time in phone settings menu: ON
TrekBuddy tech info: Timezone GMT+01:00; true; 3600000

Thank you for this great tool
Back to top
View user's profile Send private message
vincent



Joined: 11 Feb 2008
Posts: 196

PostPosted: Fri Apr 03, 2009 2:24 pm    Post subject: Reply with quote

Very Happy I've just finished my own dev and all is okay Very Happy Cool

missing only cms::time with ms precision and the coords for my next dev step Wink

it will be hard to be patient

_________________
SE K750i + 512MB MS2 OR HTC Diamond + Qstarz BT-818 + Wintec 301 + latest TB
Back to top
View user's profile Send private message
arqto



Joined: 14 Apr 2009
Posts: 18

PostPosted: Sun Apr 26, 2009 6:03 pm    Post subject: Reply with quote

User'm good Spanish, discupar my poor English.

I have installed version 83 on my blackberry storm and I have a problem while using the program, I was left in standby mode, to start the gps, changing map, a point made at the change of compass or map cms anytime we use the program, is this happening to someone else? How can I fix this?

I have also used the 84 version for Blackberry and I often spend more


thank you very much

--------

buenas soy usuario español, discupar mi pobre ingles.

Tengo instalada la versio 83 en mi blackberry storm y tengo un problema, mientras estoy usando el programa, se me queda la pantalla en blanco, al iniciar el gps, al cambiar de mapa, al dirijirme a un punto, cambiar de mapa a brujula o cms vamos en cualquier momento de uso del programa, ¿esto le pasa a alguien más? ¿como se puede solucionar?

tambien he usado la version 84 para blackberry y me pasa mas amenudo


muchas gracias
Back to top
View user's profile Send private message
guest



Joined: 08 Oct 2006
Posts: 4934

PostPosted: Thu Jul 02, 2009 9:49 pm    Post subject: new version didn't displays <desc> gpx tag Reply with quote

I am not able find (in new version 0.9.83) in weapoint detais <desc> gpx tag. I used it before. Is it wilful default? (V nove verzy neni zobrazen gpx tag <desc> s jeho obsahem. Ve starsich verzich se me jeho obsah vypise, v nove ne. Pouzival jsem to rad. Je to umyslne vynechano?) Thanx
Back to top
View user's profile Send private message Visit poster's website
kruch
Site Admin


Joined: 02 Jul 2006
Posts: 5663

PostPosted: Fri Jul 03, 2009 11:16 am    Post subject: Re: new version didn't displays <desc> gpx tag Reply with quote

guest wrote:
I am not able find (in new version 0.9.83) in weapoint detais <desc> gpx tag. I used it before. Is it wilful default?


That is by intention. Does your gpx contain both <cmt> and <desc>?
Back to top
View user's profile Send private message
guest



Joined: 08 Oct 2006
Posts: 4934

PostPosted: Sat Jul 04, 2009 10:55 am    Post subject: Re: new version didn't displays <desc> gpx tag Reply with quote

[quote="kruch"]That is by intention. Does your gpx contain both <cmt> and <desc>?[/quote]

I created easy program for quick download cache info to offline. Is posible save it to the .gpx and .csv.
Here is .gpx output example:

<gpx version="1.1" creator="TrekBuddy 0.9.81" xmlns="http://www.topografix.com/GPX/1/1" xmlns:rmc="urn:net:trekbuddy:1.0:nmea:rmc">
<wpt lat="50.773566667" lon="15.194883333"><time>2009-06-27T10:21:52Z</time><name>T_Slovanka</name><desc>[pm] na z stene skalky vedle velkeho parezu asi 2 m vysoko ve vodorovne spare.</desc></wpt>
<wpt lat="50.774133333" lon="15.167700000"><time>2009-06-27T10:21:52Z</time><name>M_Kostel sv. Jana Krtitele</name><desc>1-magnet - osmy od krizovatky</desc></wpt>
</gpx>

In treckbuddy app. 0.9.81 is possible show name and hint in <desc> tag. I would like to use 0.9.83, but <desc> in this version is hidden. I use it with <cmt> now, and it's working correctly. Thanx

PS: Which other gpx tags trekbuddy supported please? I would like to adding to gpx more geoc. informations (as listing and size). Which tags is appropriate to use on it please. Thanx for your great app.
Back to top
View user's profile Send private message Visit poster's website
vincent



Joined: 11 Feb 2008
Posts: 196

PostPosted: Sun Jul 05, 2009 5:25 am    Post subject: Reply with quote

with the last version I got an HECL huge problem that I do not explain

when done :

set averagespeed10s [/ 200 5] -> 40
set averagespeed10s [/ 200 500] -> 0
set diff [/ 1.0 10000.0002] -> 0.000

an using double casting is the same !?????


in other word I am unable to do a simple division by 10 000

_________________
SE K750i + 512MB MS2 OR HTC Diamond + Qstarz BT-818 + Wintec 301 + latest TB
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   This topic is locked: you cannot edit posts or make replies.    TrekBuddy Forum Index -> Recycle Bin All times are GMT
Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8, 9  Next
Page 8 of 9

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group