Bílý vrch
icon TrekBuddy
www.trekbuddy.net
Outdoor companion.
  • internal / bluetooth / simulator GPS
  • offline raster maps
  • smart GPX / raw NMEA logs
  • waypoints and simple navigation
  • custom views
  • MIDP and Symbian phones
  • Blackberry
  • Android
Visit wiki to see all features, guides and howtos. Project tracker - moved to github.
Trekbuddy github repository

Partners:    (Polish/Polski)(Polski) Compass mapy      (Polish/Polski)(Polski) Galileos mapy      (Polish/Polski)(Polski) CartoMedia      (Czech/Èesky)(Èesky) Eaglesoft trasy      (Polish/Polski)(Polski) ExpressMap     

 FAQFAQ   SearchSearch 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
0.9.79 RC
Goto page Previous  1, 2, 3, 4, 5, 6 ... 9, 10, 11  Next
 
Post new topic   This topic is locked: you cannot edit posts or make replies.    TrekBuddy Forum Index -> Recycle Bin
View previous topic :: View next topic  
Author Message
kruch
Site Admin


Joined: 02 Jul 2006
Posts: 5676

PostPosted: Fri May 23, 2008 5:17 pm    Post subject: Reply with quote

Smile This is exactly what shocked me yesterday (I remember no complaints about such issue from S60 users), and made me make some changes... which helped me for E60.
Back to top
View user's profile Send private message
mainframe



Joined: 02 May 2007
Posts: 16
Location: CZE

PostPosted: Fri May 23, 2008 6:23 pm    Post subject: Reply with quote

I have E50, it is strange that nobody else with S60 have seen this. Although it was not always possible to get to the error info, I should have reported it earlier.

If this helps I will be very happy, this is last major problem I have with TB. Thanks
Back to top
View user's profile Send private message
x2fer



Joined: 31 Jan 2007
Posts: 1662
Location: Madrid, Spain

PostPosted: Fri May 23, 2008 6:42 pm    Post subject: Reply with quote

In the last version, the trail line appears with a strange look, as if it had different thickness, according to the angle.


_________________
Sony Xperia M4 Aqua || N500 || C5-03 + BT-Q810 + TrekBuddy 1.33 (Español)
Back to top
View user's profile Send private message Visit poster's website
sbreit



Joined: 06 Aug 2007
Posts: 73

PostPosted: Fri May 23, 2008 8:27 pm    Post subject: Reply with quote

kruch wrote:
Update (attached here):

* one more step for thickness (7 - thick enough even for 416x352, IMHO)


What about the route line?
Was it possible to have the thickness customizable there, too?

_________________
have: Garmin GPSmap 76Cx; Nokia E1i + DiMP3; Garmin GPSmap 76
had: Nokia E70; Garmin geko 201
Back to top
View user's profile Send private message
Grzes



Joined: 22 Nov 2007
Posts: 128
Location: Katowice Poland

PostPosted: Sun May 25, 2008 6:23 pm    Post subject: Reply with quote

kruch wrote:
Update (attached here):

* one more step for thickness (7 - thick enough even for 416x352, IMHO)
* trailpoint selection algorithm now selects less points
* trail line setup changed, it is not the last one in the form, and maybe it will work better - to change between changing color/thickness selection (using LEFT-RIGHT), pres any non-gaming key (alt+number on Blackberries) or try joystick FIRE (works SEs and Nokias, as far as I could test it)


Works fine.

But the problem is sometimes the currently active setup line is covered by the down phone menue line (select, more). Secons movement works OK. It is IMHO acceptable Smile

Quote:

Please when you test trail line, try to make NMEA logs,so that bugs can be reproduced. Thanks Cool


OK ..... GPX will be not sufficient ?

regards
Back to top
View user's profile Send private message
mainframe



Joined: 02 May 2007
Posts: 16
Location: CZE

PostPosted: Sun May 25, 2008 7:46 pm    Post subject: Reply with quote

I tried latest development version during weekend and here are my experience:
- BT connection worked great, no symbian errors (but its probably too early to make conclusions)
- I'm facing the same as gisela earlier mentioned and documented by screenshot - trail line is composed of three parallel lines. It is easily visible on thinnest line, sometimes also on second thinnest. This is probably also reason for line not having same thickness for different angles.
- I got out of memory exception probably when loading some language file, it was not possible to scroll the error message and TB crashed in few seconds. I made a waypoint snapshot during the trip and I suspect there is a problem with memory after doing so. I'll test this more and report later.

Anyway, I am very happy with the new version, especially with the trail line.

_________________
BT-Q1000X
Back to top
View user's profile Send private message
guest



Joined: 08 Oct 2006
Posts: 5081

PostPosted: Sun May 25, 2008 9:50 pm    Post subject: Reply with quote

[quote="mainframe"]I tried latest development version during weekend and here are my experience:
- BT connection worked great, no symbian errors (but its probably too early to make conclusions)
- I'm facing the same as gisela earlier mentioned and documented by screenshot - trail line is composed of three parallel lines. It is easily visible on thinnest line, sometimes also on second thinnest. This is probably also reason for line not having same thickness for different angles.
- I got out of memory exception probably when loading some language file, it was not possible to scroll the error message and TB crashed in few seconds. I made a waypoint snapshot during the trip and I suspect there
is a problem with memory after doing so. I'll test this more and report later.

Anyway, I am very happy with the new version, especially with the trail line.[/quote]




Co tady řešíte? A ještě k tomu anglicky?
Tímto způsobem, čeština nikdy nebude světovým jazykem.
Prostě se to zatím nepovedlo, ale Bůh dá, a popřeje Kruhovi dobré myšlenky a nápady, a bude zase fajn.
Opravdu dobrý soft. Smile Díky.
Back to top
View user's profile Send private message Visit poster's website
j.utha



Joined: 31 Jan 2007
Posts: 23
Location: Sehnde/Germany

PostPosted: Mon May 26, 2008 4:18 am    Post subject: Reply with quote

Hi Kruch,
great job, everything worked fine the last months on SXG75, no more memory problems. Very Happy Now I’ve found a little problem: since last release track thickness and colour don’ t change anymore when buttons 4,6,2,8 are pushed, no reaction. On first beta-version these features were still ok.
Jürgen
Back to top
View user's profile Send private message
Grzes



Joined: 22 Nov 2007
Posts: 128
Location: Katowice Poland

PostPosted: Mon May 26, 2008 6:38 am    Post subject: Reply with quote

j.utha wrote:
Hi Kruch,
great job, everything worked fine the last months on SXG75, no more memory problems. Very Happy Now I’ve found a little problem: since last release track thickness and colour don’ t change anymore when buttons 4,6,2,8 are pushed, no reaction. On first beta-version these features were still ok.


You have to change the colour by joystick (left/right) then *switch* the mode by pressing joystick once and again left/right. Kruch explained it few post up ...

Schoene Gruesse Smile
Back to top
View user's profile Send private message
Grzes



Joined: 22 Nov 2007
Posts: 128
Location: Katowice Poland

PostPosted: Mon May 26, 2008 6:43 am    Post subject: Reply with quote

guest wrote:


Anyway, I am very happy with the new version, especially with the trail line.


Me too Smile

Quote:

Co tady řešíte? A ještě k tomu anglicky?
Tímto způsobem, čeština nikdy nebude světovým jazykem.


A polski tadi Wink

Jeno nektere skoli maji anglicky ..... Razz !

Ahoj ! Wink !!!
Back to top
View user's profile Send private message
mainframe



Joined: 02 May 2007
Posts: 16
Location: CZE

PostPosted: Mon May 26, 2008 11:27 am    Post subject: Reply with quote

>guest
Je mi lito, ze neumite anglicky, ale ohledy na to brat nebudu, proto existuji diskuze v Česky / Slovensky.
Back to top
View user's profile Send private message
Ranger



Joined: 12 Dec 2006
Posts: 6030

PostPosted: Mon May 26, 2008 12:20 pm    Post subject: Reply with quote

@Kruch
Pls find attached files to reproduce (simulate) 3 types of current trail bugs:
1.Thin line drawn instead thick for last segment.
2.Some trail segments not visible
3.Important trail points lost
In attachment:
1.Small TB test map with nmea logs plotted.
2.Two sample nmea logs.

@TB Users
Could you be so kind and check (using TB simulator) on which models these bugs are visible ?
It is enough to copy test map to phone, logs to tracks-nmea folder, select Simulator in Settings and use Start to see effects in phone.



trail_bugs_samples_0979_last_beta.png
 Description:
 Filesize:  9.67 KB
 Viewed:  12308 Time(s)

trail_bugs_samples_0979_last_beta.png



trail-nmea.rar
 Description:

Download
 Filename:  trail-nmea.rar
 Filesize:  201.39 KB
 Downloaded:  231 Time(s)

Back to top
View user's profile Send private message
guest



Joined: 08 Oct 2006
Posts: 5081

PostPosted: Mon May 26, 2008 1:28 pm    Post subject: Trail colour and Backlight problems Reply with quote

Hi,
You speak a lot of using the joystick left/right to change the trail colour/thickness. But when should I do this? Left/right just moves the map to left/right.

Or are there a menu item for this? Is it under Settings/Desktop?
Something strange happens when I try to scroll down below the OSD Transparency item. The scroll bar is at the bottom line, but the display shows is scrolled to the first line.

Also, there is a bug in the Backlight control. If I choose Backlight On, this setting works for a while. After a while the setting does not work. The backlight turns off. Pressing 3 again to Backlight Off and 3 again to Backlight On again does not help.

Edit: My phone is a SE K810i
Back to top
View user's profile Send private message Visit poster's website
Profa



Joined: 22 Feb 2008
Posts: 19

PostPosted: Mon May 26, 2008 2:13 pm    Post subject: Re: Trail colour and Backlight problems Reply with quote

guest wrote:

Also, there is a bug in the Backlight control. If I choose Backlight On, this setting works for a while. After a while the setting does not work. The backlight turns off. Pressing 3 again to Backlight Off and 3 again to Backlight On again does not help.

Edit: My phone is a SE K810i


On K800 and K770 it works OK.

_________________
SE Satio+16GB, SE K550i+8GB, TB+hafo map Smile
Back to top
View user's profile Send private message
Grzes



Joined: 22 Nov 2007
Posts: 128
Location: Katowice Poland

PostPosted: Mon May 26, 2008 5:12 pm    Post subject: Reply with quote

x2fer wrote:
In the last version, the trail line appears with a strange look, as if it had different thickness, according to the angle.



I have similar effect on my K750i.

I am afraid the various line thickness (sometimes -1 + 2 pixels) is depend on the angle. Lines nerly vertically are sometimes more thick. Bit I am not able to determine the dependence. GPS track doesn't show anything abnormal. I will try to record NMEA track. Tomorrow a bit with my bike Smile

Regards
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   This topic is locked: you cannot edit posts or make replies.    TrekBuddy Forum Index -> Recycle Bin All times are GMT
Goto page Previous  1, 2, 3, 4, 5, 6 ... 9, 10, 11  Next
Page 5 of 11

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group